Requirements

For best results in Delta's Extranet, please use:

  • Windows Vista with Microsoft Internet Explorer v7.x
  • Windows XP with Microsoft Internet Explorer v6.x using MS Java VM
  • Windows XP with Internet Explorer v6.x using Sun Java v1.4 or above
  • Windows XP with FireFox 1.5.x and Sun Java v1.4 or above
  • Macintosh OS 10.3.x with Firefox v1.5 and Apple Java v1.3 (no eCrew)
  • Macintosh OS 10.3.x with Safari v1.3 and Apple Java v1.4
  • Macintosh OS 10.3.x with IE 5.2 and Apple Java 1.3 (no eCrew)
  • Macintosh OS 10.3.x with Netscape v1.7 and Apple Java 1.3 (no eCrew)

Some content may require Adobe Acrobat Reader or a Flash plug-in.

For certain pages to function properly, we recommend that cookies, JavaScript, and Java be enabled in your browser preferences. Disabling any of these features or using a different or older operating system or browser may reduce or impede site functionality. Your questions regarding Help Desk support, cookies, operating systems, browser settings, and other subjects may be answered on the Help page.

Known issue: Macintosh Safari packaged with the Leopard operating system is not compatible with TravelNet. Please use Firefox until such time as the issue with this version of the Safari browser can be identified and addressed.